DX10 Scenery Fixer

$23.99


Compatibility and Requirements

Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10 all 32/64 bit.
(Windows XP does not support DX10 and so is not supported!)

Microsoft FSX SP2,Gold or Acceleration or Steam Edition.

Systems using multiple unlinked GPUs (i.e without SLI) are not supported (this is a restriction in FSX core)

Also note that several people have reported issues using FSX DX10 Preview with Laptop "Optimus" solutions.

Test that DX10 Preview mode runs on your system before purchase!